Jonjs 发布的文章

科目:得分/满分 // 班级排名 // 年级排名

总分:806/1050 // 3 // 461

语文:108/150 // 22 // 788
数学:109/150 // 12 // 715
英语:117/150 // 2 // 148

理综:218/300 (72.7%)
|-- 物理:72/110 // 34 // 1268
|-- 化学:70/100 // 13 // 662
|-- 生物:76/90 // 9 // 619

文综:255/300 (85.0%)
|-- 政治:79/100 // 1 // 299
|-- 历史:79/100 // 16 // 482
|-- 地理:97 // 2 // 42

1.打开 Git Bash
1-extra.(若第一次使用, 必须进行此步骤!): 新建.git文件夹(若不存在, 则无法添加远程仓库)

$git init

1-extra.(若第一次使用, 必须进行此步骤!): 配置用户信息

$git config --global user.name "Name"
$git config --global user.email "Email"

2.添加远程仓库

$git remote add Project HTTPS

注意:此处一定要选择HTTPS格式的git地址,SSH配置比较麻烦,暂时不考虑。

3.切换到某个本地目录

$cd C:/Users/Somebody/Desktop/BukkitPlugin/

4.查看目录结构,准备跟踪文件(夹)

$ls

5.提交到缓存

$git add File.txt
$git add Folder/

6.提交 commit

$git commit -m "信息"

7.推送到远程仓库

$git push Project

方式:GET
请求地址:https://pan-yuhang.top/lib/MsgBox/msgbox.php
参数:
*参数<1> msg => 文本信息 - String
参数<2> color => 背景颜色 - Enum(COLOR)
若参数<2>为空,则无背景色
返回:
HTML页面 - Html Page
注意:
枚举常量COLOR包含:

  • info
  • success
  • warning
  • Hex颜色

示例:https://pan-yuhang.top/lib/MsgBox/msgbox.php?msg=示例文本&color=info

此API最后更新:2020/2/22 13:00

最近一直想搞这个,一下子试验成功了,就来发个帖,避免以后频繁在其他网站上搜索,浪费时间。
试验完成后一定要清理一下你的注册表!
(2020/2/18更新) 软件新思路:程序被唤醒后写入配置项,原来已开启的程序使用时钟检测命令行是否被更改,若更改,配置项再次写入一个close=true,可让新程序销毁,原程序开始获取网页内容。
(2019/6/5更新) 软件设计思路:时钟检测命令行是否被更改,被更改取新,并销毁新程序;未被更改则销毁新程序。

小提示:程序人为打开一次后可以写一次注册表,路径取运行目录+执行文件名即可,随机应变。

代码(例如在test://中,test就是头)

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\F1]
@="URL:头 Protocol Handler"
"URL Protocol"=""

[HKEY_CLASSES_ROOT\头\shell]

[HKEY_CLASSES_ROOT\头\shell\open]

[HKEY_CLASSES_ROOT\头\shell\open\command]
@="程序路径(双反斜杠) "%1""

外部参数传入程序:
例子:test://?hash=233
你需要在“_启动窗口创建完毕”子程序下写入以下代码,以便接收传入的参数:
(子程序代码)

.版本 2
.支持库 spec

    取命令行 (命令行数组)
    .判断开始 (取数组成员数 (命令行数组) = 0)
        调试输出 (“无参数”)
    .判断 (取数组成员数 (命令行数组) ≠ 0)
        调试输出 (“参数是:” + 命令行数组 [1])

(定义程序集文本型数组)

    .版本 2
    
    .程序集变量 命令行数组, 文本型, , "0"

外部访问1:test://?hash=233
参数接收1:test:///?hash=233(多一个/,所以别忘了替换一下)
外部访问2:test://model9s(必须以字母结尾)
参数接收2:test:///model9s/(后面多一个/,所以别忘了替换一下)

感谢阅读
资料引用:http://bbs.eyuyan.com/simple/?t306972.html

价格:ESP8266 15+5(邮费)
总计:20
风险警告:超过8人连接热点,芯片会过热,自行承担后果
所需资源下载:【ZIP文件】

ESP8266是干啥的?
ESP8266可以当WiFi信号中继器来玩呀,详情自行百毒

如何制作一个WiFi中继器?
慢慢阅读吧,这个应该很容易成功

---制作过程---
1.购买ESP8266板子(下称板子)
我买的这个是适合小白的,因为我也刚入手哈哈哈,烧录时不需要按键
链接:https://item.taobao.com/item.htm?spm=a1z10.3-c-s.w4002-16248799899.33.39ea546e5rHk8s&id=530849464226
买回来大概是这个样子的:
img1

2.连接板子和电脑
USB口就是小口的那种,oppo vivo充电线
不建议使用USB2.0,可能会出错
连接完成后,右键“计算机”,选择“管理”,点击“设备管理器”,找到“端口(COM和...)”分支,
如果你看到了一个“CH340”端口的话,说明一切正常,此时,记录下括号里的COM号码,
我的是COM3

3.烧录
下载所需资源,解压,将根目录中“中继器.bin”文件移动至某个硬盘下,路径最好不要带中文和空格!
打开“固件烧录器”文件夹,运行“ESP8266Flasher.exe”
(1)在COM Port右侧选择你的COM号码
(2)点击[Config],切换子夹,把第一个小框框前点一下,打上叉,意思是启用,
长条填入bin文件路径,最右侧是偏移地址,填写0x00000即可
(3)点击[Advanced],4个下拉框分别选择:

  • 115200
  • 1MByte
  • 40MHz
  • DIO

(4)回到COM Port那个界面,点击Flash按钮即可

期间需要等待2~5分钟,速度有点慢
左下角显示绿色对号就可以关掉程序了

4.设置热点
运行根目录下“串口调试助手.exe”程序,调整左下角的串口,点击打开串口,
然后把按钮下面的“发送新行”的多选框选中,
右侧1、2、3、4、...左边依次输入:
set ssid 你家WiFi的名字
set password 你家WiFi的密码
save
set ap_ssid ESP8266热点的名字
set ap_password ESP8266热点的密码
save
show
然后依次点击右侧的1、2、3、4、...等按钮

最后,按一下板子上的“RESET”小按钮就可以啦~

本站已开启强制HTTPS访问
那么,如何实现呢?
在你的网站文件中加入下面的脚本代码:

<script type="text/javascript">
    var targetProtocol = "https:";
    if (window.location.protocol != targetProtocol)
    window.location.href = targetProtocol + window.location.href.substring(window.location.protocol.length);
</script>

若是博客,建议放在footer.php或header.php中,index.php不建议,index页面可能不被所有页面调用

由于各种原因,博客炸了又炸,现已基本重建,但不准备恢复之前的数据了,因为我挺懒的。
这个主题我会在日后尝试魔改一下的,能不能改成win10样式呢233333.
到时候再看看能不能新增个评论功能233.